
 

 

 
This document will explain how to use ShapeLayerToolbar. 
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Shape Layers in After Effects 
If you are not familiar with Shape Layers or would like to know all, then take a look at the section at the bottom 
of this document about native ways to add to shape layers in After Effects.  



ShapeLayerToolbar 

 
ShapeLayerToolbar features: 

★ Your personal shape layer element settings 
★ Easily save and set shape layer elements, including: 

○ every value 
○ expressions and the values hidden by active expressions 
○ gradients (through an animation preset) 

★ Add expression controls with a button 
★ Save and load all settings 
★ Easily select all elements of one type 

 

Installation 
From CC2019 onward you can install from the menu: File > Script > Install ScriptUI Panel 
Add both ShapeLayerToolbar.jsx and The ShapeLayerToolbar folder to the ScriptUI Panel folder. 
Restart After Effects and load ShapeLayerToolbar.jsx from the window menu. 
 
Or do a manual install: 

1. Place the extracted contents of ShapeLayerToolbar.zip into your After Effects ScriptUI folder. 
Example paths: 

Mac: ~/Applications/Adobe After Effects Cc 2018/Scripts/ScriptUI Panels/ 
Windows: C:\Program Files\Adobe\Adobe After Effects Cc 2018\Support Files\Scripts\ScriptUI Panels\ 

2. Relaunch Adobe After Effects if currently open. 
3. Launch the script from the Window menu by selecting ShapeLayerToolbar. 

 
ShapeLayerToolbar.zip contents: 
 

ShapeLayerToolbar.pdf 
ShapeLayerToolbar.jsx 
folder: ShapeLayerToolbar 

fill black soft edge CC13 0.ffx 
fill black white black CC13 0.ffx 
fill rainbow CC13 0.ffx 
fill zebra CC13 0.ffx 
ShapeLayerToolbar-Default-Settings.txt 
stroke default CC13 0.ffx 
stroke red glow CC13 0.ffx 
stroke shadow-ish CC13 0.ffx 
stroke zebra CC13 0.ffx 

 
  



Settings 

 
This button will bring up the settings menu, where you can choose how the toolbar behaves, save and load 
your settings and a few settings regarding the adding of shape layer elements. 
 

 
The general settings, including: 

Layout Horizontal block Buttons Toggle for each button 
Horizontal responsive Toggle for info 
Vertical block Toggle for checkboxes 
Vertical responsive 

Groups handling Add into group 
Add next to group 

Add One Adds one at the first selected property. 
For each selected value Adds one for each selected property. 

Selection Select all element values after adding element 
Select only the element after adding element 

Save Load and set autoload Save settings to file 
Load settings from file 
Set autoload file path 
Clear autoload file path and revert to defaults 

 



 
The merge menu lets you set the merge buttons, including shift, ctrl and alt settings for each button. 
 

 
The Advanced menu shows settings for using gradients when using a different menu language and allows you 
to turn off setting the tooltype to pen after adding an empty path. 
 



 
The License menu shows register info and the License Help button leads to the “Deactivate License”-button if 
needed. 
 

  



Record & Play 

 
This button lets you switch between Record and Play mode. 
 

 
In play mode buttons are blue. 
 

 
In record mode buttons are red. 
 
In record mode you can save four settings per button of that element type, for example for square: a small 
square, a big square, a circle from a square and a square taking comp dimensions with expressions. 
The script allows you to name your settings. Cancelling this will stop the script from saving the settings. 

Creating Shape Layer Elements with ShapeLayerToolbar 

This is the part doing  
All these buttons have to do with shape layers. 
 



 
Click:  add a new shape layer to comp. 
Shift click:  select children of the current selection. One level down. Type: SS to show in the timeline. 
Ctrl click:  open/close your selected paths. 
Alt click:  get the createPath formula of a path as its expression. 
 

Add: Save:  
Add and save one of four predefined groups. 
 

 
Add and save one of four x5 predefined shape paths. 
An empty shape path will autoset your tooltype to the pen tool, so you can start drawing straight away. 
 

 
Add and save one of four predefined circles, ngons or rectangles. 
 

 
Add and save one of four or eight predefined filter settings. 
 

 
For the merge filter, a button for each setting. Settings of the buttons can be changed in the menu. 
ShapeLayerToolbar will place a new merge path below the other filters and above existing stroke and fill. 
Unlike adding a merge path with the dropdown, which will place it at the bottom of the selected level and add 
the settings of the fill and stroke according to the After Effects toolbar. 
 

 
Add a fill, stroke, gradient fill or gradient stroke. 
Gradients are saved as animation presets for which you will be prompted a location to save and open. 
The gradients which come with ShapeLayerToolbar are backwards compatible from CC 2014 or version 13.0. 

Creating Expression Controls with ShapeLayerToolbar 

 
Save and Add any of the predefined settings of the expression control effects to your layer. 
Including any combination of expression controls. 
 

 
Add and save an expression control slider. 
 

 



Add and save an expression control point. 
 

 
Add and save an expression control 3d point. 
 

 
Add and save an expression control angle. 
 

 
Add and save an expression control checkbox. 
 

 
Add and save an expression control color. 
 

 
Add and save an expression control layer selector. 
 

 
Add and save multiple expression controls. 
 
Note that you can actually add any number or kind of expression controls to any of these expression control 
buttons. 

Saving Expressions 
Expressions that are turned off when saved to the toolbar, will be turned on when that element is added. 
ShapeLayerToolbar does not remember whether an expression is on or off. 

Selecting Elements 
To select all shape layer and expression control elements of one kind: shift + ctrl + click a button 

Checkboxes 
 

These checkboxes influence what happen when you add an element to a shape layer. 
‘in or next to group’ This allow you to add element into a selected group or at the same level as the group. 
‘one or multiple’ This allow you to add one element or one element for each selection. 
‘values or element’ This allow you to have all values selected after adding so you can open them up with 
SS. 

Or just have the element selected. 

What ShapeLayerToolbar doesn’t do 
ShapeLayerToolbar doesn’t save: 

○ no blending options 
○ no material options  
○ no visibility settings of elements 
○ no keyframes  
○ not more than one shape layer element setting at a time 



○ gradients work from CC2014 or version 13.0 onward 

Add to Shape Layers - Native 
Creating Shape Layer Elements - Native After Effects 
 

You probably know this dropdown very well.  
It is accessed from the toolbar and at the top of each shape layer. 

You need to click this tiny round button to open it:  
 
The dropdown contains four types: 

➔ Group  
● sets coordinates system 

 
➔ Shapes 
● sets parametric shapes and bezier paths 

 
➔ Graphic elements 
● gives fills and strokes to shapes 

 
➔ Filters 
● changes the attributes of the above 

 
When you add these elements with the dropdown they will appear:  

- new shapes and groups below existing shapes and groups 
- filters below existing filters 
- graphic elements at the bottom 

 
When you add an element it will be selected. And after adding a group, the 
subsequent elements will be added into that group. 
 
Adding a merge path with the dropdown, will place it at the bottom of the 

selected level and add the settings of the fill and stroke according to the After Effects toolbar. 
 
Groups can be nested, making shape layers act as a “precomp in a layer” with its own parenting structure. 

Creating Shape Layer Elements in the Composition Viewer 

Another way of adding shapes is with the native After Effects toolbar tools. 
 

 
Here you can select parametric shapes or a path with the pen tool. 
 

 
By selecting the Bezier path checkbox at the end of this toolbar or by pressing alt while drawing a parametric 
shape it will instantly become path. While!! doing this you can press the spacebar to position the shape. 
 

 
Drawing with these tools will automatically create a group in your shape layer with a fill and stroke as set in the 
toolbar. 
 



 
By pressing Q you can select one of the parametric shapes. 
 

 
By pressing G you can toggle between the pen tool and the mask feather tool. 
The mask feather tool won’t interact with your shapes or do anything if you haven’t already got a mask on your 
selected layer. 
 

 
This selector will decide whether you draw shape layer shapes or mask paths. 

Keyboard Shortcuts 
 
Some basic shortcuts 
These shortcuts come in handy when you are using shape layers: 
 
ss show selected, after you have added a new element 
u open keyframes 
uu open altered values, if altered from  
e open effects / expression controls 
ctlr + ‘ toggle expansion of effects properties 
ee show expressions 
/ switch focus between composition and timeline 
 
Shape layer shortcuts 
g sets tool to pen tool and cycles trough them 
v sets tool to pointer 
ctrl + g group your selected elements 
ctrl + shift+ g UNgroup your selected elements 
ctrl + d duplicate selected 
 
ctrl + alt+ home set anchor point to the middle of the layer 
ctrl + home center selected layer 

  



Other Shape Layer Knowledge 
Gradient Fill or gradient Stroke Compviewer Interface 

 
Set start and end point of your gradient with this line. 

 
Set the highlight with this circle. This position will translate into % and angle. 
 

 
Linear and radial gradient UI. 

 
To get the gradient fill UI or the gradient stoke UI in the compViewer you need: 

- A gradient fill or stroke 
- A group the gradient is in 
- Some shape at the same level as the gradient 
- The pointer tool 

 

Set Bezier Handle Size 
You can set the size of Bezier handles and vertices in the preferences: 
Win: Edit > Preferences > General 
Mac: After Effects > Preferences > General 

Shape Layer Brain Freeze, when AE doesn’t respond 
When you add to many filters AE can freeze up. 
This can occur when you accidentally duplicate wiggle paths. 
This filter will break up your paths and shapes to consist of more subdivision. If you have the filter twice it will 
try to subdivide those subdivision again. 
Breaking up one path segment into 100 path segments and each of those again into 100 etc can add up. 
Depending on how long ago your last save was, it is often faster to restart AE when this happens. Sometimes 
you get the chance to turn off the filter when AE temporarily unfreezes before preparing the next frame. 



Merge paths, what’s going on? 
When you are using more that one “Merge Paths” filter at the same time, it helps to group the different parts 
you are merging. Sometimes you need explicitly add the implicit “Merge Path” set to Merge or Add. 
 

 
For example: when you want to subtract one circle from two squares,  

you need to add the implicit “Merge Paths” set to Merge or Add. 
 

 
Grouping can add some clarity, but you still need to add the implicit Merge Paths. 



 

Colofon 
About me 
Hey, I’m Daan Dirk the creator of ShapeLayerToolbar. 
 
More about me on: 
http://www.daandirk.com/  

Links 
Adobes resources on Shape Layers: 
https://helpx.adobe.com/after-effects/using/overview-shape-layers-paths-vector.html 
 
https://helpx.adobe.com/after-effects/using/animating-shape-paths-masks.html  
 
https://blogs.adobe.com/creativecloud/creating-motion-graphics-with/  
 
 

Other not to miss shape layer tools: 
 

- Buttcapper 
http://www.battleaxe.co/buttcapper/  
Change line caps and joins of a selection, with a button. 

 
- Convert Shapes 

https://gumroad.com/l/convert-shapes 
Converting circle and square paths back to parametric shapes 

 
- Explode Shape Layers 

https://aescripts.com/explode-shape-layers/  
Splits all groups from a layer to new layers and merges shape layers into one layer. 

 
- Ray Dynamic Color 

https://aescripts.com/ray-dynamic-color/  
Controlling colors with a toolbar. 

 
- Shape Repeater Baker 

https://aescripts.com/shape-repeater-baker/  
Brings the repeater settings to the needed number of groups. 

 
- Trim-Pack 

https://gumroad.com/l/trimpack 
Trim-pack will add trim path and keyframes at once for selected layers. 
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